Issue Details (XML | Word | Printable)

Key: FDT-2897
Type: Bug Bug
Status: Confirmed Confirmed
Priority: Trivial Trivial
Assignee: FDT Team
Reporter: Martin Møller
Votes: 0
Watchers: 4
Operations

If you were logged in you would be able to see more operations.
FDT

FDT hangs when saving a file

Created: 16/Aug/12 09:10 PM   Updated: 21/Jan/16 01:17 PM
Component/s: None
Affects Version/s: FDT 5.6, FDT 5.6.1, FDT 5.6.2
Fix Version/s: FDT
Security Level: public

Time Tracking:
Not Specified

File Attachments: None
Image Attachments:

1. Screen Shot 2012-10-04 at 4.57.48 PM.png
(240 kB)
Environment: Mac OS X 10.8. MacBook Air Mid 2011, SSD, 4GB


 Description  « Hide
Experiencing hangs when saving a file. Sometimes only a few seconds, others up to 10 seconds. Happens often both on normal save and autosave prior to refactoring. Could maybe be a SSD issue?

 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
FDT Team added a comment - 30/Aug/12 06:20 PM
Please provide some more info please, such as screenshots or video. The problem could be most anything.

FDT Team added a comment - 03/Sep/12 02:39 PM
Any news on this?

If not, Ill close this ticket. If it happens in a consistent way (reproducible) please let us know.


Robert Payne added a comment - 14/Sep/12 04:15 AM
I can confirm this happens, its hard to reproduce reliably I cannot currently find a consistent set of steps that causes it to happen.

I am also using an SSD and am making a Adobe AIR application. I'll try to provide more information when I can.


Martin Møller added a comment - 14/Sep/12 09:52 AM
Sorry for my inactivity. I have completely overlooked the first two comments.

When saving a file (CMD + S) the save file dialog pops up and it is like the entire application hangs for 2 - 10 seconds. Not every time CMD + S is hit but often.
I will try to do a screencast and provide more information when possible. I am about to start a new project in FDT and the issue will of course have my attention.

Since I posted the issue I have been working on a PHP-project in NetBeans and I actually experience kind of the same problem. However, it happens with auto completion. When auto completion is popping up in NetBeans I sometimes experience hangs for a few seconds as well. I know this is not a NetBeans community but both NetBeans and FDT are, as I know of, based on JAVA cores. JAVA/SSD could possible be a direction to look.


FDT Team added a comment - 14/Sep/12 02:12 PM
Interesting. Thanks for the update.

Robert Payne added a comment - 03/Oct/12 11:20 AM
Yea I Martin's comments are exactly what is happening on mine as well. It's actually quite hard to determine what exactly causes it but it sorta seems when changing quite a bit of code and trying to immediately save causes it like the compiler/indexer may be trying to do something to the file before a save is allowed?

It's preventing me from using FDT for the time being because it's prevents you from doing anything while it's saving.


Martin Møller added a comment - 03/Oct/12 12:34 PM
This issue seems to be closed. Is it possible to re-open it?

FDT Team added a comment - 03/Oct/12 02:44 PM
What is FDT doing when it's 'saving'? Does it say anything. Is it building the workspace?

It might be related to FDT having to rebuild it self after a lot of changes. If you have a project where this can be reproduced, please let me know.


Robert Payne added a comment - 04/Oct/12 06:00 AM
I've attached a screenshot of immediately when this happened. It's hard to reproduce though it does occur often just randomly when saving.

It's a bit annoying because again it's a modal pop-up and blocks you from doing much of anything while waiting for it which can sometimes go for 4-10 seconds.

This particular time it shows the "building workspace" other times I've had it just on the save.

The project literally has nothing in it but this single code file you can see.


FDT Team added a comment - 07/Nov/12 02:19 PM
Does this still happen? Does it occur with the new FDT?

Martin Møller added a comment - 07/Nov/12 03:08 PM
Yes it still happens. Currently working in FDT 5.5 and haven't upgraded to the new version so I have no idea if it the problem persists.

Robert Payne added a comment - 10/Feb/13 01:26 PM - edited
Any update on this? It's annoying as heck when editing every 3-4 saves causes a good 3-6 second delay.. not so fun for rapid development.

Should note I'm running the latest FDT


Robert Payne added a comment - 26/Mar/13 01:09 AM
Hi so after talking with Steve from support and enabling the new "Separate Auto Build Thread" the problem seems to have only gotten worse. Again this happens on saving a file and the dialog strictly says it's waiting for the Save to complete.

Here are my computer specs:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,3
Processor Name: Intel Core i7
Processor Speed: 2.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB

I'm running a 256GB 6gbit Solid State drive from OCZ.

Using eclipse with Flash Builder doesn't produce the same hangs so I'm at a loss on what is happening.


Robert Payne added a comment - 26/Mar/13 01:12 AM
More information to potentially help:

It seems to happen most when saving after creating a new variable somewhere

IE:

1) Create new project
2) Open main class file
3) Add: var sprite:Sprite = new Sprite()
4) Save
5) Experience hang

every time I repeat steps 3-5 it creates another hang. Attached is the screenshot that I get when using the separate auto build thread


Robert Payne added a comment - 26/Mar/13 01:22 AM
Couple more finds:

• It never happens if code assist is turned off
• It never happens if the code assist panel never pops up ( copy and pasting code lines )


Stephanie Swiderski added a comment - 26/Mar/13 10:11 AM - edited
Hi Robert Payne,

If the separate auto build thread makes it even worse you can switch it off again.

its a strange thing since in windows it seems to occur with very low frequency.
My co-worker creating also large projects with FDT on a Mac there it also occurs in very low frequency. We test several times on his machine.
There must be some special circumstance in your setup which creates the problem.

Which SDK do you use in your test projects?
Do you use the plugin version of FDT or the Standalone?
If you use the plugin version into which Eclipse Version you installed it?
Do have installed other eclipse plugins (mabye they interfere with FDT plugins)?

Maybe you could create a workspace with only the test project which creates the problem?

To the five steps: In step three how do you add the new variable with copy and past or with auto completion.
Do you add a local variable or a field?

"It never happens if code assist is turned off"
What do you mean by that? do you mean "Enable auto activation"?

How many projects do you have open in your workspace during you test these five steps?
You can try to close all other projects you don't work with to increase speed.

Is there your workspace on the same hard drive as eclipse (in some special circumstance user expierence
a slow down if the workspace is on da different drive then the workspace)?

Do you run any other tool which access the harddrive during you work with FDT?
(Sometimes the system blocks on a file access if another thread is listening to file changes)?

I am really interested in hunting down this issue.

Regards,
Stephanie Swiderski


Robert Payne added a comment - 11/Apr/13 07:29 AM
Hi Stephanie,

1) I'm using AIR 3.6 SDK though also experienced this with AIR 3.5 SDK earlier in the bug history
2) I use FDT Standalone directly downloaded from your website, have deleted and reinstalled several times
3) Not that I'm aware of – this happens with stock standard FDT
4) I can reproduce this with 1 project with 1 code file only and nothing else in my workspace
5) I'm adding that line of code just by typing it out. If I copy and paste it it does not hang but if the code assist panel pops up it nearly always hangs
6) I'm adding it as just a local variable
7) By "code assist" I mean when you use cmd/ctrl + spacebar to show the auto completions panel that shows you the context aware completions. Sorry if terminology is incorrect here
8) 1 Project open only, have deleted and re-created several times
9) Yes this is all running off my primary and only HD which is a SSD with 6gb SATA speed
10) I run nothing special that should be messing with the project files out of the ordinary.

Extras:

• I've tried this both with the separate auto build thread on and off
• Flash Builder ( seperate app standalone ) never experiences hangs following same steps
• It appears to be "building" that is hanging not the actual "save" operation

My computer is a:

Early 2011 17" Macbook Pro
256GB SSD 6gb/s
16GB Ram

Hope this helps in some way

-Robert


Stephanie Swiderski added a comment - 16/Apr/13 10:45 AM
Hi Robert Payne

thank you for your answers.
It narrows down the problem range a bit.
Maybe you can test also this:
If you switch of "build automatically" the popup should not occur,
this may verify that the combination build automatically and saving provokes the popup.

I think the problem is a timing issue. I.e. that the file is already saved caused by the speed of you harddrive the auto build pops in too early
and provokes the popup and the delay.

I try to get a machine setup like yours to recreate the issue and to find a fix.

Regards
Stephanie Swiderski


Simon Rodriguez added a comment - 19/Apr/13 04:19 PM
Hi

I'm having similar problems as Robert, disabling "Build Automatically" removed the "Building Workspace" task when I'm trying to save(CMD+S) but it would still freeze on "Save". But after disabling my antivirus software (NOD32) fixed that right away. So now my problem is that with "Build Automatically" enabled it still freezes on save.

So, is it possible to get the description how to enable "Separate Auto Build Thread" ?

I have similar specs as Roberts MBP but with 128GB SDD and 4GB ram.

Thanks!

-Simon


Stephanie Swiderski added a comment - 19/Apr/13 04:33 PM
Hi Simon Rodriguez,

In the last FDT we have the Separate Auto Build Thread removed since it does not work out as expected.
But we have add new idea you can activate it at Preferences/FDT/Misc/Information on (PDE RunTime) Error Log/ Extra Building (unsafe)
it is still in unsafe beta mode but maybe it helps. Our local test have brought some improvements.

What kind of os your are using (also MacOS)?

Regards
Stephanie Swiderski


Simon Rodriguez added a comment - 19/Apr/13 05:03 PM
Hi Stephanie!

That did the trick for me! Everything seems to run fine, tried it on a coworkers computer as well.
Reenabling my antivirus still showed the save dialogue, but I have excluded FDT and my workspace from it, and now it works.

Thank you for your help!

Im running Mountain Lion(Latest) and my coworker is running Snow Leopard.

-Simon


Stephanie Swiderski added a comment - 19/Apr/13 05:32 PM
Hi Simon Rodriguez

thank you for your feedback.
Please watch the situation with save and the editor behaivour
since this fix is in beta and we want ot be sure if we should put it into the
next release as standard.

Regards
Stephanie Swiderski


FDT Team added a comment - 28/Aug/13 04:04 PM
Is this still an issue?

We changed quite a bit with the last few releases.

If this isn't an issue anymore, I'll close this. If it continues please come back and comment on it and we'll reopen it.


Simon Rodriguez added a comment - 29/Aug/13 05:12 PM
This has started to show again in the later releases, I still have 'Extra Building' still on, but it stalls very often.

Stephanie Swiderski added a comment - 29/Aug/13 05:19 PM
Hi Simon Rodriguez,

maybe try to switch off Extra Building now
we have changed alot maybe this has the reversed effect now.

Have you still excluded FDT and your workspace from your antivirus software?

Regards
Stephanie Swiderski


Simon Rodriguez added a comment - 29/Aug/13 05:30 PM
Turned off 'Extra Building' and 'Build Automatically', but still seeing the issue.
I have my FDT and workspace folder excluded from my antivirus (ESET NOD32).

Jeff added a comment - 13/Sep/13 04:33 PM
Please fix this issue!!, I was migrated from FB and FDT is truly awesome, but this "tiny bug" is enough reason to come back to Flash Builder

Stephanie Swiderski added a comment - 24/Sep/13 04:10 PM - edited
We have add a beta option in the last release of 23 September 2013 which might avoid this issue.

Try to activated: Preferences/FDT/Misc/Use direct thread (unsafe)