Issue Details (XML | Word | Printable)

Key: FDT-1678
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Critical Critical
Assignee: FDT Team
Reporter: Martin Dom
Votes: 1
Watchers: 0

If you were logged in you would be able to see more operations.

Cannot create new Flash Project directly after installing FDT4

Created: 08/Dec/10 02:42 PM   Updated: 22/Jun/12 07:01 PM
Component/s: UI
Affects Version/s: FDT 4.0
Fix Version/s: FDT 4.5
Security Level: public

Time Tracking:
Not Specified

File Attachments: 1. Text File Configuration.txt (325 kB)
2. Text File ErrorLog.txt (473 kB)

Image Attachments:

1. access denied unzipping AC_OETags.jpg
(235 kB)

2. access denied unzipping flex sdk 3.jpg
(227 kB)

3. wizard SDK not found.jpg
(93 kB)
Environment: Windows Vista Home Premium, Java 1.6.0_13

 Description  « Hide
Cannot create new Flash Project directly after installing FDT

The following actions do not give any reaction at all, no error message, no new screen:

  • Link on Welcome Screen
  • Selecting file - new - new flash project
  • Selecting new - new flash project in the project browser

Selecting the project wizard with file - new project results in the new project wizard.
Here, selecting flash - new flash project and clicking Next does not react on the first click.
On the second click, the new flash project wizard appears.
Giving a project name, leaving the defaults web and as3 project, and clicking finish does not give any reaction (the button reacts graphically, but returns to "clickable, not clicked" appearance). Same with Next button.

At this point, the dialog cannot be closed, neither by Cancel nor by the Windows X.

For differential diagnosis: a java project helloworld could easily be created, compiled and runs in the same workspace and directories. This should rule out any file privilige causes.

The error log shows e.g.

!ENTRY org.eclipse.ui 4 0 2010-12-08 14:18:57.766
!MESSAGE Unhandled event loop exception
at com.powerflasher.fdt.internal.ui.views.wizards.NewProjectConfigureBuildPathPage.dispose(
at org.eclipse.jface.wizard.Wizard.dispose(
at org.eclipse.jface.wizard.WizardDialog.hardClose(
at org.eclipse.jface.wizard.WizardDialog.close(
at org.eclipse.jface.window.Window.handleShellCloseEvent(
at org.eclipse.jface.window.Window$3.shellClosed(

!ENTRY org.eclipse.ui 4 0 2010-12-08 14:19:44.138
!MESSAGE Unhandled event loop exception
at com.powerflasher.fdt.ui.composite.SdkComboViewer2.correctSdkSelection(
at com.powerflasher.fdt.ui.composite.SdkComboViewer2.setSdkName( ...

 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Martin Dom added a comment - 08/Dec/10 02:43 PM
Current Configuration, directly after installation.
Error log

Philipp Arnolds added a comment - 08/Dec/10 06:20 PM
Have you done a plugin or standalone installation of FDT? Have you tried "reset perspective"?

Martin Dom added a comment - 08/Dec/10 07:21 PM
-> standalone installation (see attached file configuration.txt)
-> just tried reset perspective, no result, i.e. still cannot create a flash project

Maybe Problem FDT-1023 had similar reasons:
Although I followed the install procedure and did not change any such files.

What I did change was to increase the memory for eclipse as described in the FAQ.
But only after several fails when trying to create a flash project

Philipp Arnolds added a comment - 09/Dec/10 06:46 PM - edited
Please try the following:
  • close FDT
  • go to the FDT Project template folder and delete the file "sdks.xml"
  • restart FDT

Starting FDT after doing that will take a while because FDT will recreate both SDKs that are shipped with FDT. If you have setup custom SDKs you will have to reconfigure them again.

you can find the FDT Project Template folder here:


/Users/Powerflasher/Library/Application Support/FDT

assuming "Powerflasher" is the username


Martin Dom added a comment - 09/Dec/10 09:25 PM
Tried deleting sdks.xml.
Turns out, there is NO such file. In no folder anywhere near.
Tried with an empty sdks.xml file. No change, same problem.

Uninstalled FDT
(by the way: this leaves the Project Template folder C:\Users\Powerflasher\AppData\Roaming\FDT intact ! Should delete these folders too)
Downloaded the setup for windows standalone ftd4 again around 19:00 today (9.12.2010).
Ran setup again. (no chance to do anything wrong here).

Apparently new Version running now. This version checks the availability of sdk on startup, at least gives some error messages. At least on the first start after installing it does. On all other launches of FDT4, no error messages appeared.

Error Messages complained about "access denied" for certain files, which were supposed to be located in some zip files.
The error messages are shown in the attached screenshots, together with the explorer showing the actual tree of folders and files that are available.

Note that the path in the error message do not exactly match the path in the file system.

After ignoring the error messages, I tried to create a new flash project anyway.
Same problem, although some of the above mentioned error messages appeared again, (see attached screenshot within the wizard).

Martin Dom added a comment - 09/Dec/10 09:28 PM
2 Error messages on first startup of FDT4 after installing. Plus the actual contents of the folders.
1 Error message within new project wizard.

Philipp Arnolds added a comment - 10/Dec/10 10:21 AM
FDT needs do extract the SDKs, windows silently restricts this if it is installed in Program Files

The most easiest way to make FDT run would be to simply install FDT in the directory that is suggested by the installer by default: C:\FDT

If you want to have FDT installed in the programs folder you can manually extract the SDK zip files:

  • inside of the plugins directory of FDT find the folders "com.powerflasher.fdt.shippedFlexSDK_3.5.0.12683a_1000" and "com.powerflasher.fdt.shippedFlexSDK4_4.0.0.14159_1000"
  • each of them contain a sdk zip file that need to b extracted to a folder called "flex" in both directories
  • after restarting FDT the SDK should get configured automaticly, if not you may need to point FDT to the two flex folder you created: Preferences => FDT => Installed SDKs

Martin Dom added a comment - 10/Dec/10 04:28 PM
Thanks a lot.
That did finally help.I extracted the .zip files and copied them to the new folder flex.
I got to run the basic examples of the tutorial, i.a. creating a flash project does work now.

Note by:
I would consider this behavior of the installer a bug.
If the installation runs correctly only for C:\FDT without the aforementioned tweaking, the user should be informed. Or simply do not allow an installation at any other place. Third option: make FDT installable in the folder program files like all other programs I installed so far.

Thanks again for your quick and helpful reaction.

Tyler Wright added a comment - 23/Jan/11 04:39 AM
It's important that things like this 'just work' out of the box. FDT should install to the Program Files directory by default, like every other Windows program. Perhaps better not to zip the SDK's at all but ship them unzipped, rather than frustrating someone new to FDT. Minimizing frustrations (especially early ones with installs and setting up projects) are critical for adoption.