Issue Details (XML | Word | Printable)

Key: FDT-2325
Type: Improvement Improvement
Status: Closed Closed
Resolution: Fixed
Priority: Trivial Trivial
Assignee: FDT Team
Reporter: Panel
Votes: 0
Watchers: 0

If you were logged in you would be able to see more operations.

Change launch configuration naming conventions

Created: 09/Sep/11 04:35 PM   Updated: 22/Nov/12 04:35 PM
Component/s: Launching
Affects Version/s: FDT 4.5.3
Fix Version/s: FDT
Security Level: public

Time Tracking:
Not Specified

Review Type: Review by Product Owner

 Description  « Hide
When running class for the first time as "FDT SWF Applicaion" the default name is set for class name. Since in most cases Main class is startup class (this is also default class created in new each project) and in most cases there is only one class launched from project I believe naming convention should be updated.
I believe simple change to projectName_className would be nice improvement, because it's describes launching configuration bether

 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Alan K (Deprecated) added a comment - 09/Sep/11 05:26 PM
Interesting idea, I would like a 'smoother' way of naming the default naming convention.

The problem with changing the name is...what do we change it to? If we change an existing behavior of something, then it should be as universally accepted as possible - otherwise people who are used to it, and perhaps like it, will be upset.

Since it's really easy to just rename the configuration to whatever someone likes....I don't think it's worth the effort to change when when we can be using the time to work on bugs.

You've had some great ideas over the last few days and I'd like to have those first.

Panel added a comment - 12/Sep/11 05:48 PM
It's just the idea witch came out while I was using FDT. I strongly believe that if something may be done without user interaction - it should be done automatically

Now if you run 5 new projects you'll get proper ruining configuration
Main (1)
Main (2)
Main (3)
Main (4)

But wouldn't be nice to have sth like this with project name prefix?

I agree you are changing existing behavior, but still it's quite obvious change? Isn't it? ...and user don't have to change project name each time creating new project.

I understand this is small thing and I 100% agree that there are many more important things do, but I believe it's small usability changes like this that creates great software It looks like very small task from developer perspective, and I strongly believe it will be nice and useful improvement of FDT.

BTW thx Alan for appreciating my other ideas

Panel added a comment - 04/Nov/11 03:27 PM

FDT Team added a comment - 22/Nov/12 04:35 PM
Implemented for next release: 22. Nov