Issue Details (XML | Word | Printable)

Key: FDT-2407
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: FDT Team
Reporter: Kevin
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
FDT

I can not resolve an error "application descriptor not found" when I try to launch a mobile application on the desktop

Created: 06/Nov/11 12:54 PM   Updated: 22/Jun/12 07:01 PM
Component/s: AIR
Affects Version/s: FDT 5.5.2
Fix Version/s: FDT 5.5
Security Level: public

Time Tracking:
Not Specified

Environment:
Windows 7 Home Premium 64bits
FDT 5.5.1.1513
Flex SDK 4.5.1.21328
AIR SDK 3.0

Review Type: Review by Developer


 Description  « Hide
This bug is still persistent in FDT 5.5.1.1513.. Just create empty hello world project (type AIR for Desktop) and still getting "application descriptor not found" message!
I checked the .settings>launch file and the key is there : <stringAttribute key="ADL_DESCRIPTOR_FILE" value="bin/AirDemo-app.xml"/> but it still doesn't run / debug and all I get is the application descriptor not found" message.

 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Kevin added a comment - 06/Nov/11 01:02 PM
It should be noted that I try to compile a Flex mobile project.
As3 mobile projects work fine.

Richard Jewson added a comment - 16/Nov/11 01:17 PM
I have the same issue, on AS3 or Flex projects.

The problem seems to be that the ADL command generated doesn't contain the actual name of the descriptor.xml file.


Philipp Arnolds added a comment - 17/Nov/11 04:13 PM
thanks for your reports!

have you renamed the application descriptor?
does this issue also occure on a fresh Hello world project?


Richard Jewson added a comment - 21/Nov/11 03:01 PM
Its the standard Hello World project, and I didnt rename anything

Jonathan Kaye added a comment - 23/Nov/11 03:48 PM - edited
I am seeing this same problem, with the same configuration – not even "Hello, World" – just trying to run the files created from the wizard. Oddly enough, when I run the same project on my device, it works fine.

SOLUTION:
I actually had one project working on my machine and another project not working – giving the error. So I tracked it down into the .settings > launch folder, for my app called "trycompile", the file .settings > launch > trycompile.launch. In the working version, FDT had inserted the line:

<stringAttribute key="ADL_DESCRIPTOR_FILE" value="bin/workingapp-app.xml"/>

but this was absent in the non-working file. So I added the following line to that file:

<stringAttribute key="ADL_DESCRIPTOR_FILE" value="bin/trycompile-app.xml"/>

When I added that line, now the project works. Yay!


zh. added a comment - 07/Mar/12 10:44 AM
I have same problem every time I create new [FDT Mobile Application] Run Cofiguration.
Solution works, but I don't want to make it every time I create new config.

Philipp Arnolds added a comment - 08/Mar/12 10:47 AM
this issue is marked as revolved, which means that we have implemented a solution for that. The fix for that will be included in the next update.

Skyrick added a comment - 23/Mar/12 10:35 PM
You can simply delete the XXXX-app.xml and recreate a new one on the properties Export > Building > Application Descriptor : works fine for me