Issue Details (XML | Word | Printable)

Key: FDT-2472
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: FDT Team
Reporter: Joey van Dijk
Votes: 1
Watchers: 7
Operations

If you were logged in you would be able to see more operations.
FDT

Flex SDK 4.6 breaks FDT during compile

Created: 30/Nov/11 07:07 PM   Updated: 22/Jun/12 07:01 PM
Component/s: AIR, ANT
Affects Version/s: FDT 5.0
Fix Version/s: FDT 5.5
Security Level: public

Time Tracking:
Not Specified

Environment: Mac OS 10.6 Snow Leopard
Issue Links:
Duplicate
 


 Description  « Hide
When using ANT <fdt.launch.application> as always, I found out today (and previously with other 4.6 betas) that I get an exception during compilation:

java.lang.NullPointerException
at com.powerflasher.fdt.core.launch.debug.DebugSessionManager.getDebuggerFor(DebugSessionManager.java:50)
at com.powerflasher.fdt.core.launch.debug.DebugSessionManager.launchSessionFor(DebugSessionManager.java:97)
at com.powerflasher.fdt.core.launch.debug.DebugSessionManager.launchSessionAndKillOld(DebugSessionManager.java:137)
at com.powerflasher.fdt.core.internal.launch.debug.concrete.DebuggerStarter.run(DebuggerStarter.java:47)
at com.powerflasher.fdt.core.launch.AbstractTargetStarter.runListenerStarters(AbstractTargetStarter.java:61)
at com.powerflasher.fdt.core.launch.swf.SwfStarter.run(SwfStarter.java:58)
at com.powerflasher.fdt.core.internal.launch.compile.concrete.CompilerProcess$1.run(CompilerProcess.java:226)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Session-data:
eclipse.buildId=M20110909-1335
java.version=1.6.0_29
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86, WS=cocoa, NL=en_US
Framework arguments: -product com.powerflasher.fdt.product.product -keyring /Users/joeyvandijk/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86 -product com.powerflasher.fdt.product.product -keyring /Users/joeyvandijk/.eclipse_keyring -showlocation

I am only calling FDT ANT tasks like they are working with Flex SDK 4.5(.1) with all AIR versions (2.6 / 2.7 / 3.0), but apparantly something is crashing. It occurs when building for AIR3.0 and FP11.0 + AIR3.1 with FP11.1.

Its a big project so I cannot share it, but because it previously worked with different AIR versions (and with or without AIR3.1 / FP11.1 changed definitions) but not any more with this new Flex SDK. I saw also that the SDK from opensource.adobe.com (4.6.0.23201 Adobe Flex version) is default now an AIR setup (possibly due to flash plugin choices).

Any tips on sharing more debug information would be helpful, while I only grasped it from the Error Log in Eclipse.

Hope you can discover whats happening, while this error I also got using the beta/prerelease versions of Flex SDK 4.6, so I presume it has to do something with the way FDT uses the Flex SDK compiler.

FYI



 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
John Olson added a comment - 01/Dec/11 04:19 AM
Having same error but just using regular debug session from FDT.

Philipp Arnolds added a comment - 01/Dec/11 03:08 PM - edited
Thank you guys for your reports!

We were able to resolve the issue and a fix will be released via the FDT 5 update site quite soon.

workaround

Luckily there is a easy workaround that will resolve the issue for you as well:

  • Go to your flex 4.6 SDK
  • edit the content of flex-sdk-description.xml from:
<?xml version="1.0"?>
<flex-sdk-description>
<name>Flex 4.6.0</name>
<version>4.6.0</version>
<build>23201</build>
</flex-sdk-description>

to:

<?xml version="1.0"?>
<flex-sdk-description>
<name>Flex 4.5.0</name>
<version>4.5.0</version>
<build>23201</build>
</flex-sdk-description>

Germain LECOURTOIS added a comment - 08/Jan/12 03:11 PM
Thanks Philipp, this workarounf fix my error on FDT 5 Max ( 64bit Mac Os X 10.7 )

Error for Air 3.1 on Desktop for iPhone and Android, but no error in Device publication.

But questions:

  • The compiled file stay in Flex 4.6 ?
  • Any update soon to fix this issue ?

Thanks !

Germain, an Happy FDT 5 max owner ( and happy for years )


hexagonstar added a comment - 22/Feb/12 03:58 AM
Still getting this bug with latest update FDT 5.0.0.1460.

Christian Pugliese added a comment - 28/Feb/12 01:46 PM
Any news on this?
Workaround did not work for me with AIR 3.1 and now still not working with AIR 3.2.

Ain Tohvri added a comment - 05/Mar/12 03:52 PM
I can confirm the above workaround mentioned by Philipp works nicely.

derRaab added a comment - 11/Apr/12 10:20 AM
I'm using the latest Version of FDT 5 but this issue still exists. Anyway the workaround works. When will we get FDT 5.5?

Alan K (Deprecated) added a comment - 11/Apr/12 04:10 PM
@derRaab,

Stay tuned this week for a beta.


Ain Tohvri added a comment - 17/Apr/12 12:11 PM
I can confirm this works seamlessly now in 5.5 Beta http://fdt.powerflasher.com/2012/04/fdt-5-5-beta-released/